IPB

Witamy gościa ( Logowanie | Rejestracja )

 
Reply to this topicStart new topic
Lenovo B590 + Linux, prawdopodobnie problem z UEFI
mshm
dodano 17-07-2013, 19:42
Nr wypowiedzi: #1





Grupa: Forumowicz
Wypowiedzi: 39
Rejestracja: 28/04/13
Nr użytkownika: 55 264



Witam.
Niestety posiadam problem z nowo zakupionym laptopem Lenovo B590 na architekturze Intela i3 ivy bridge. Otóż zakupiłem laptopa bez systemu operacyjnego, z myślą o zainstalowaniu na nim linuxa (wybór padł na aptosid lub lmde), co niestety okazało się dla mnie przerostem formy nad treścią. Nie jestem co prawda początkującym użytkownikiem, wcześniej korzystałem z debiana przez ok. 2 lata, tak więc nie straszne są mi komendy itp...
Jednak problem przerósł moje możliwości biggrin.gif
W gruncie rzeczy mam problem z każdym linuksem, którego próbowałem zainstalować (LMDE, Debian Testing, aptosid). Otóż nagrywam obrazy na cd tudzież pendrive, i odpalam przy bootowaniu lenovo (czysty dysk smile.gif ). Włączam instalator, partycjonuję dyski w sposób dla mnie dogodny, instaluję system poprawnie (wszystko przebiega tak, jak należy, włącznie z grubem).
Problem pojawia się, gdy po instalacji restartuję notebooka. Łączy się przez DHCP nie wiadomo gdzie, po czym przestaje, i wywala mi wybór napędu do bootowania... ustawiam co prawda dysk twardy, ale z powrotem wyrzuca mnie do menu wyboru. W ogóle nie uruchamia się grub.
Wnioskuję po przebyciu internetu, iż problem pojawią się z UEFI, co uniemożliwa mi działanie gruba, i wymusza instalację nielegalnego windowsa 8. W internecie znalazłem taki oto link, w którym ładnie facet wyjaśnij, co zrobić w biosie, aby móc na moim notebooku zainstalować linuxa:

http://zameer.nl/blog/?p=1794

Mimo wszystko, ten sposób nie działa. Próbowałem kilku innych, przez zabawę w biosie, jednak nic to nie daje. Nie jestem po prostu w stanie zainstalować linuxa, a walczę z nim już od 2 tygodni. Masakra.
Czytałem także o dyskach - GPT oraz MBR. Konwertowałem dysk GPT na MBR przez gparted, gdisk itp... także nic z tego.
Czy ktoś z Was miał podobny problem, niekoniecznie z tym samym modelem laptopa, i odnalazł rozwiązanie?
To niedorzeczne, że rezygnując z systemu windows na notebooka i tak muszę być na niego skazany, bo producent tak sobie wymyślił. Sił już do laptopa nie mam, a do serwisu w ramach wymuszenia od serwisantów instalacji linuxa nie chcę wysyłać laptopa.
Czy da się w jakiś sposób ominąć UEFI lub całkowicie go wywalić, tak, abym mógł korzystać z zainstalowanego linuxa?
Pozdrawiam.
Go to the top of the page
 
+Quote Post
ciernik68
dodano 22-09-2013, 18:28
Nr wypowiedzi: #2





Grupa: Forumowicz
Wypowiedzi: 93
Rejestracja: 13/06/11
Nr użytkownika: 39 978
Laptop: Pro Book 470



nie znam się na linuksie ale może to pomoże?

http://www.thomas-krenn.com/pl/wiki/Instal...tformach_z_UEFI
Go to the top of the page
 
+Quote Post
dither
dodano 17-10-2013, 14:20
Nr wypowiedzi: #3


Niezmienny


Grupa: Forumowicz
Wypowiedzi: 88
Rejestracja: 1/04/11
Nr użytkownika: 38 173
Laptop: Lenovo x230/i7-3520M/16 GB RAM/256 GB SSD/Arch Linux



Fedora lub ubuntu poradza sobie od reki z uefi. Arch linux ma dobre wiki na temat instalacji uefi samemu


--------------------

Too weird to live too rare to die.
Go to the top of the page
 
+Quote Post
kony
dodano 1-01-2014, 10:05
Nr wypowiedzi: #4





Grupa: Forowicz
Wypowiedzi: 668
Rejestracja: 4/09/13
Nr użytkownika: 56 939
Laptop: XPS 13 9360



Starsze (i czesc aktualnych dystrybucji) linuksy podobno maja okropny problem z dzialaniem wlasnie z tym UEFI, nawet jesli skonfigurujesz go jak nalezy. Dla przykladu dopiero wersja 15 i 16 (obydwie z 2013 roku) Linux Mint potrafi na nich dzialac bez problemu, proba instalacji poprzednich wersji (w tym LTS) konczy sie tak jak u ciebie, wnioskujac z tego co przeczytalem na oficjalnym forum LM. Sprobuj zainstalowac najnowsze Ubuntu/Linux Mint i tymczasowo uzywac ich dopoki Debian nie bedzie w stanie bezproblemowo dzialac na UEFI, chyba, ze juz sa odpowiednie dystrybucje specjalnie pod to. W kazdym razie chyba lepsza mainstreamowa dystrybucja linuksa, niz Windows 8 wink.gif


--------------------
Moje byłe eGPU: T430, Pe4l 2.1b, GTX 560Ti
Moje kolejne byłe eGPU: T430, EXP GDC 8.0, GTX 670
h y p e r b o o k | g a m e r a g o n | x t r e e m | d r e a m m a c h i n e s
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 użytkownik(ów) przegląda ten wątek (1 gości i 0 użytkowników anonimowych)
0 użytkowników:

 



RSS Wersja Lo-Fi_|_Informacja o cookies Zegar wskazuje: 13-11-2019 - 0:17